Sie sind nicht angemeldet.

1

Dienstag, 28. Februar 2012, 20:24

Umlaute werden nicht korrekt angezeigt

Hallo Fabian,

irgendetwas funktioniert am Gästebuch nicht richtig.
Die Umlaute äöü und ß werden nicht korrekt angezeigt, wenn man einen Eintrag verfasst hat und diesen abschickt. Ich habe nun alle Templates überprüft, kann den Fehler aber nicht finden.

Kannst du bitte nochmal schauen?

Danke dir!
Lg Steffi

2

Mittwoch, 29. Februar 2012, 12:53

Hallo Steffi,

da scheint die Kodierung der EIntragsseite bzw. der Gästebuchseite falsch zu sein. Das kann zwei Ursachen haben:

1. Im Header-Bereich fehlt diese Angabe:

PHP-Quelltext

1
<meta http-equiv="content-type" content="text/html; charset=ISO-8859-1">


2. Die Dokumente selbst sind falsch abgespeichert worden. Auch hier muss die Kodierung ISO-... lauten und nicht UTF-8. Das kannst du normalerweise in deinem Editor umstellen.

Viele Grüße,
Fabian Karg

>>> www.flf-book.de
Zufrieden mit Service und Support? Dann schau Dir doch mal die Premiumfeatures an ;)

3

Mittwoch, 29. Februar 2012, 20:48

Das ist komisch. Ich habe z.B. für die Seite gaestebucheintragen.html die gleiche Vorlage betzistierwelt.dwt verwendet, wie z.B. für die index-Seite. auf der Indexseite ist der Quellcode richtig, als mit dem iso-88..., auf der gaestebucheintragen.html nicht, obwohl die gleiche Vorlage verwendet wird? ?(

Edit: Habe die Vorlage nun neu abgespeichert ... jetzt funktioniert es wieder :)

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »betziswelt« (29. Februar 2012, 21:59)


4

Dienstag, 6. März 2012, 17:19

Sehr schön ;)
Zufrieden mit Service und Support? Dann schau Dir doch mal die Premiumfeatures an ;)

Thema bewerten